Jump to content
Macro Express Forums

Macro Won't Run Correctly In Windows Xp Sp2


ejs
 Share

Recommended Posts

I have 3 macros, each containing only one macro command... clipboard cut, clipboard copy, or clipboard paste, which are assigned to hotkeys F2, F3, and F4 respectively.

 

I am running Windows XP Pro SP1, with macro express v 3.7a. These macros run correctly in all applications, including when I use the hotkeys to invoke the macros within macro express itself. For example, I can use these hotkeys in the macro express scripting editor / macro script pane to copy and paste the macro commands in the script.

 

I gave my .mex to a colleague who is running Windows XP Pro SP2, with macro express v 3.7a. We did a "macro open file" to load the .mex file on his system (not a import macros, so I know there are not any conflicts between my macros and hotkeys and anything he may have previously defined).

 

The macros run correctly in every application on his machine EXCEPT for the macro express scripting editor / macro script pane. The macros definitely are invoked in the macro script pane when the hot key is pressed (because I put in a text display box as a diagnostic to confirm that the macro is really running). But for some reason, the clipboard cut, copy, and paste commands don't produce the desired outcome when the item they are cutting, copying, or pasting is a command within the macro script pane. Either nothing happens, or the selection highlighting changes to a different command in the macro script, depending on which command was highlighted when I pressed the hot key. (I have tried changing one of these macros so instead of a clipboard copy command, it uses a text type with control c, but this also does not do a copy within the macro script pane.)

 

Does anyone know why this would happen in Win XP Pro SP2 but not in SP1? Any suggestions on how I can fix it? Should I report this to insight as a bug?

 

Thank you

Link to comment
Share on other sites

This may be due to a difference in speed between the computers. Try setting the Text Type delay in the preferences by clicking Options, Preferences, Delays. We recently changed Macro Express to set a default of 300 microseconds but it does not change existing values. So if it is 0 try 300. If it is 300 try something bigger like 900.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...