Jump to content
Macro Express Forums

Unwanted capslock character


amuller
 Share

Recommended Posts

I'm trying to use the "Text Type function" to fill up a form. If I use the command <DELETE>FRA_R002<TAB>, marco express type FRA_R==" converting 002 in ==". If I do not mentionn <DELETE>, then FRA_R002 is OK, or if I put <DELETE>FRAR002<TAB> (without underscore), it's correct. It seems that <DELETE> or underscore have an influence on numbers which are then converted in caps. I use a swiss frenc keyboard where numbers are typed without shift. Can someone explain why this phenomen occurs ? André

Link to comment
Share on other sites

Most likely this is being caused by the program you are automating. To determine whether or not this is the case, run your macro in Notepad and see if it occurs there.

 

You may have some success splitting the command up like this:

Text Type: <DELETE>
Delay 0.25 Seconds
Text Type: FRA_R002<TAB>

When you do a Text Type using uppercase letters what is sent to your application looks like this:

<SHIFT DN>F<SHIFT UP>

It is possible that the application you are automating does not have time to react to the <SHIFT UP> that is automatically sent. You may try something like this:

Text Type: <DELETE>
Text Type: FRA_R
Delay 0.25 Seconds
Text Type: 002<TAB>

Another thing to try would be to set the shift using the Shift Key command like this:

Text Type: <DELETE>FRA_R
Shift Key Down
Shift Key Up
Text Type: 002<TAB>

You could also try slowing down the typing of text using the Keystroke Speed command:

Keystroke Speed: 100 Milliseconds
Text Type: <DELETE>FRA_R002<TAB>
Keystroke Speed: 0 Milliseconds

Or you can adjust the Text Type speed for all macros by adjusting the 'Use Text Type delay' option found in Options, Preferences, Delays. Recent versions of Macro Express default this value to 300. You might try an even larger number.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...