Jump to content
Macro Express Forums

why doesn't my macro work on another computer?


Recommended Posts

I wrote a macro for a friend but it won't run on her system. The macro is supposed to select a word or words in Adobe Acrobat Professional 8, copy it into a Word document, type a tab, and return to Acrobat. (There are four variations of the macro with some slight differences--and not all of them return to Acrobat. Some just stop after copying into Word so that the user can type in other things.) I set the macros up and tested them thoroughly on my system in the trial version of Macro Express Then I went to my friend's house, installed the trial version of Macro Express, copied my *mex file onto her system, and opened the macro file; the macro was there, everything seemed fine. BUT the macro just doesn't even start. She's working in Adobe Reader 6, not Adobe Acrobat, but I thought it should still work (I changed the path appropriately for the last step) since we are only dealing with keyboard shortcuts and Windows copying/pasting operations and switching windows. (Originally I thought she was working in a trial version of Adobe Acrobat Pro 7.) It's as if her system isn't reading the keyboard shortcut for the macro, so nothing happens. We're both on Windows XP SP2 and Word 2003, so it appears the only significant difference in the two situations is that she's in Reader and I'm in Acrobat. I tried "Restore Keyboard and Mouse Hooks," but that didn't make a difference.


The only other thing is that I didn't export my macros and then import them; I just copied the file. But they looked just the same in the Script Editor as they did on my system. What could be the problem??

Link to comment
Share on other sites

Here is what I would try first. Write a simple one line macro to type text or display a message. Test the macro and see if this runs on her computer. If it doesn't then another application running on the computer is most likely blocking the hooks.


You already tried the Restore Keyboard Hooks option. Try restarting Macro Express and then test a macro. If this fails, look at other applications running on the computer, especially those that run in the background. It could be that a setting to a firewall or anti-spyware program needs to be changed. Try closing down applications one by one and test Macro Express after each program closes.


If your new macro did work, then check the scope on your original macro. Set it to global and try the macro again.

Link to comment
Share on other sites

You said, "It's as if her system isn't reading the keyboard shortcut for the macro...."


Did you check Properties for the macro, on her computer, to be sure the activation keystrokes are still set? I have had occasional problems like that when there was already a macro on the system with the same activation sequence. Also double-check that the macro is not disabled on her machine. I know these sound like insultingly simple suggestions, but since I have made both mistakes more than once I don't feel bad about recommending them to you....

Link to comment
Share on other sites

Hi Bob,

The keyboard shortcut still showed up everywhere I looked. I even tried making a different shortcut, twice, to see if a simpler shortcut might work. I would think it is not speicific shortcuts that are the problem, given that NONE of them worked and they also did not invoke any other actions within the application. If they were programmed to do something else, wouldnt they have done that something else instead of running my macro?



Link to comment
Share on other sites

  • 2 weeks later...
I give up. How about Stan's suggestion to write a new, one-line macro on her PC? Did you try that?


Hi rberg,


I've been out of town and then didn't get over to my friend's until yesterday. Turns out the problem was the scope. When I wrote the macro it started in Adobe Acrobat on my system. My friend was using Reader, not Acrobat. I had changed the program to start in to Reader, but I hadn't known that I had to change the scope separately. It was Stan's suggestion of changing the scope to global that made me look at the scope. But once the macros began to run, I encountered another problem entirely. I'll start a new thread for that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...