Jump to content
Macro Express Forums

Xp Sp2 Has Introduced A Problem


dlawton
 Share

Recommended Posts

Several Macros which run automatically are not running since I installed XP SP2. They all contain Visual Foxpro Programs and when the macro tries to run that element of the macro, a security window comes up saying "Do you want to open this file?" The publisher of the PRG is shown as an unknown and the window requires a click on Open or Cancel to progress.

 

I have tried entering text type left arrow, enter in the macro but no good.

I have gone through all the security settings on the pc but cannot find anything which makes any difference.

 

HELP!!

Thanks

David

Link to comment
Share on other sites

I wonder if the message is caused by the Windows Firewall. Does the title of the warning message provide a clue about which program is displaying the warning?

 

Windows XP SP2 enables the Windows Firewall unless you are using another firewall program. I do not use the Windows Firewall if I remember correctly I read somewhere where one of the 'features' was the ability to detect if one process was trying to launch another and warn the user. I would look through the settings in Windows Firewall. If you can't find it, perhaps there is a forum where they discuss Windows Firewall?

 

There is another possibility. When I download an installation file from the Internet using IE and then click on it to run it, a dialog comes up (sometimes after a long delay) that tells mentions the company name and whether a site certificate is valid. If I download using Firefox or Opera this does not occur. (There is a setting within IE to turn this feature off.) Were the Visual Foxpro programs downloaded via IE?

 

 

More on Firewalls:

Having a firewall is far better than not having one. However, the Windows Firewall does not protect your computer from processes that are trying to send information from your computer to the Internet (outbound). There are many other firewall programs out there, (some are even free for non-commercial use) that provide both inbound and outbound protection.

Link to comment
Share on other sites

Thanks for the help, found an answer in the following:-

 

 

"Run gpedit.msc, and go to Local Computer Policy->User

Configuration->Administrative Templates->Windows

Components->Attachment Manager and enable "Default risk level for file

attachments", and then enable "Inclusion list for low risk file types"

and add to this list the file extensions that you want to open without

triggering this crap."

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...