Jump to content
Macro Express Forums

Cannot use minus sign in Shortkey


Recommended Posts

In ME3 I activate macros with shortkeys like p-l, p8-1, s-mm, etc. But in ME Pro when I try to enter the minus sign when assigning a shortkey it is ignored. No character is entered.

 

Yet those old ME3 macros do work in ME Pro, i.e. I can activate them with ##s-mm etc.

 

---------

 

A little later I discovered that I can fix this by removing the minus sign from the list of 'punctuation characters'. But Help says these only apply to Suffix shortkeys, not Prefixes which I'm using. And I do not have 'Use Punctuation Chars' checked anyway. So something seems wrong.

 

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

In ME3 I activate macros with shortkeys like p-l, p8-1, s-mm, etc. But in ME Pro when I try to enter the minus sign when assigning a shortkey it is ignored. No character is entered.

 

Yet those old ME3 macros do work in ME Pro, i.e. I can activate them with ##s-mm etc.

 

---------

 

A little later I discovered that I can fix this by removing the minus sign from the list of 'punctuation characters'. But Help says these only apply to Suffix shortkeys, not Prefixes which I'm using. And I do not have 'Use Punctuation Chars' checked anyway. So something seems wrong.

 

 

--

Terry, East Grinstead, UK

 

Hi Terry,

 

I had a similar experience with the same solution.

 

Under Help I found this:

Punctuation Characters

 

The Suffix activation method allows the use of punctuation characters to trigger the macro. The Preferences image above displays the default list of punctuation characters that can be used to activate a shortkey macro. Punctuation characters may be added or removed from this list

 

Which is indeed confusing. Maybe the fact that those characters aren't being allowed in the shortkey is a bug?

Link to comment
Share on other sites

Hi Terry,

 

I had a similar experience with the same solution.

 

Under Help I found this:

 

 

Which is indeed confusing. Maybe the fact that those characters aren't being allowed in the shortkey is a bug?

 

Thanks Steve. I expect Kevin or Stan will look at this and let us know what's up.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...