Jump to content
Macro Express Forums

Duplicate network version of file opening


Recommended Posts

Quick version: MEP unintentionally loads the same file twice, one with the UNC path and the other local. It has happened a couple of times and I can't figure out what's causing it. Any ideas?

 

Long version:

I have a server that runs several macros unattended and most of the action is performed on the local file system. The file is on the local hard drive but initially I used the UNC network path because all the rest of the macros operate that way. EG \\server\data\Macro Name.MEX versus c:\data\Macro Name.MEX. But I changed that at some point so that it used the local path. Tested all my macros with a few minor changes and they all worked fine. Because I'm changing some things I disabled all but two macros which run on a schedule.

 

Now at different times I've noticed an I/O Error 32 on the one macro complaining that is can't access the file or something to that effect and the other complains that files it's trying to act on are no longer there. The first is appending, building, a TSV file and the other is zipping and deleting some files as an archive routine. After some head scratching I noticed that MEP Explorer has two instances of the same file open. One has the UNC path and the other is the local path. I think what is happening with the macros is that two instance of the exact same macro are executing at the same time and interfering with the other.

 

This is the second time I've noticed the two instances of the same file open. The first time I found that I had the "File0" in the reg set differently in the HKLM versus the HKCU and fixed it so both were the local path. But somehow it's crept back in and the registry is all correct.

 

At one point in the beta days we had a problem that a Macro Run command linked ot another macro file would open that file and leave it open causing scheduled macros and such in that file to run as well. But that was fixed ages ago and I don’t' see any Macro Run commands that have a path defined.

 

With only the local file open I have executed both of the scheduled macros and it remains the only file open. I logged off and back on and it's the only file open. I can't think of anything else to try.

 

Does anyone have any idea how this could happen?

Link to comment
Share on other sites

I figured it out.

.....................................

It was the system tray icon. It was referencing the old UNC path. But in working with it I can now see I don't like the way it's displayed with not path and all that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...