Jump to content
Macro Express Forums

Let MEP use , as decimal sign


Recommended Posts

Hi all,

 

I just installed MEP on my new win 7 pc.

Now all macros with some math in it dont work anymore because MEP uses a .

as decimal sign. And all of my old macros use a , as decimal sign.

I already set windows to use a , as decimal sign but this doesnt work for me.

 

Any sugestions ?

 

 

Greetings,

 

Wilm

Link to comment
Share on other sites

Welcome to the forum, Wilm.

 

I'm not clear what you mean. Are you saying that you had ME Pro (or ME3?) running under another OS with macros using a comma as decimal separator which worked fine? But these no longer work under Win 7?

 

Perhaps you could post a small example, and attach the MEX file.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Welcome to the forum, Wilm.

 

I'm not clear what you mean. Are you saying that you had ME Pro (or ME3?) running under another OS with macros using a comma as decimal separator which worked fine? But these no longer work under Win 7?

 

Perhaps you could post a small example, and attach the MEX file.

 

--

Terry, East Grinstead, UK

 

 

Yes Terry,

 

I was using ME pro on a xp machine and installed it now on my new win7 machine.

The xp machine was configured in time and date settings to use a , as decimal sign.

Now i installed ME pro in my win7 machine. In first instance i forgot to set de , as decimal sign

in windows so i changed that after i installed ME pro. But ME keeps using a . as decimal sign.

For example if i convert text string "7,5" to decimal i get 75.

 

 

Wilm

Link to comment
Share on other sites

I don't have Win 7 but I expect the dialog is roughly similar to my XP Pro which looks like this:

 

DecimalSeparator.jpg

 

So, as Kevin says, I'd think it would just be a matter of terminating ME Pro, ensuring the separator is specified as a comma in your Win 7 Control Panel dialog (using Customize if necessary, as in my screenshot), and then re-starting ME Pro.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

I don't have Win 7 but I expect the dialog is roughly similar to my XP Pro which looks like this:

 

DecimalSeparator.jpg

 

So, as Kevin says, I'd think it would just be a matter of terminating ME Pro, ensuring the separator is specified as a comma in your Win 7 Control Panel dialog (using Customize if necessary, as in my screenshot), and then re-starting ME Pro.

 

--

Terry, East Grinstead, UK

 

 

 

I tried this again and now it worked.

 

 

Thanks !!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...