Jump to content
Macro Express Forums

Macro does not exist in second iteration of loop


Recommended Posts

Hello All,

 

I'm new here and I didn't want to necrobump an old thread.

 

I have been continually adding functionality to a set of almost 100 macros that work together like a system that automates a whole bunch of tasks. This runs on a dedicated computer, and the idea is to run it and let it do its thing for several days.

 

All of the macros are "No activation" macros, there is one main macro that is set up as an infinite loop in which other macros are called, and I export this macro as playable for the whole thing to be manually run on demand.

 

I've developed this over the span of about a year, and it's been working great, however recently I'm getting a "Macro does not exist (0x000E)" error when running the playable macro.

 

- I know the macro exists

- It is spelled correctly in the Macro Run command

- The optional macro file field is always empty for any Macro Run command

- I never experience this error when I run it from the script editor (test run), and we've resorted to running it this way (however this is not suitable for us)

 

What's funny is that, when I run the playable macro, it all works fine for the first cycle of the infinite loop; the error only pops up the second time around.

 

Just for testing purposes, I disabled the Macro Run command that was causing the error, and the error popped up for a different Macro Run command. Hence, this problem is not specific to that single specific command.

 

I am using Macro Express Pro 4.2.2.1 on Windows XP SP3

 

Any suggestions to determine the cause of the problem and fix it?

Link to comment
Share on other sites

No clue. I suggest you contact ISS support. If you want our help I recommend creating a simple MEX and MXE file combo that demonstrates the problem and post it here with instructions.

Link to comment
Share on other sites

I'm not sure how I'd be able to create MEX and MXE files to upload and demonstrate this as it would have to go through the ~100 macros (and all the system specific scripts) to iterate through one cycle.

 

I wish I knew how :)

 

I suppose this post is more an attempt to see if others have experienced something similar or may be familiar with the problem and/or how to fix it based on the description alone.

 

ONE THING I FORGOT TO MENTION:

 

The MXE file sits on a network drive (as does the MEX and all the other relevant bits). We've always run it from one designated computer, but the macro files that have been developed have always sat on a network drive. Could this have something to do with it? Just thought I'd ask first before I attempt to reconfigure it all to work on a local drive.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...