Jump to content
Macro Express Forums

Running Man/x button won't stop this..


patgenn123
 Share

Recommended Posts

Hello everyone.

 

I should have posted this a long time ago because it has annoyed me since I purchased this program.

 

I will explain.

 

Simple action: Create repeat with folder/End Repeat. Simple macro, right?

Testing it: 1) Click Green Arrow to test it 2)Clicking Red Arrow prematurely won't stop it when clicking' red X" or right clicking "running man".

 

I have to terminate the macro by going to "File"/Terminate Macro Express Editor"and Macro Express disappears.

 

Extremely annoying.

 

Neither one of these actions Stop the X or stop the macro, but terminating ME does and it makes me mad.

 

Is there any other way of ending the macro, but not terminating ME?

 

P

Link to comment
Share on other sites

I've never had a problem ending a loop where I have had to terminate ME but I do think there's a delay in the F9 running. I think what's happening is that the macro itself is running ahead and the display of the cursor position in the Scripting Editor lags behind. I'm not sure about this and I've not had time to test it but that's the impression I get.

 

If you make a sample macro I'd be happy to try it on my system and see if I get the same result. I do have a folder with about 25k subfolders I use for testing so I could try something with that.

 

But to answer your question the only other way I know to do what you want is to use the abort keys on the keyboard. I don't remember what the default is because I like to redefine mine to "Pause" and "Break" so it's easy for me to remember. I doubt it will act any different but it might be worth a try.

Link to comment
Share on other sites

Cory,

 

Thanks for the reply. Nice to hear from you again!

 

Well, all you have to do is create a repeat with folder, choose any folder you like to run, press the green button to get it going, then try to stop it with the red x or the running man. It won't stop right away. The red x won't go away and if you choose to terminate it with the running man, ME will say that it stopped, but the red X is still there.

 

What can be done to stop it?

 

Pat

Link to comment
Share on other sites

<REP3:07:000004:000001:0001:0:01:C:\><ENDREP>

I wrote this simple macro and fired it off several times. In the beginning it worked flawlessly stopping the macro each time I clicked the red X. Granted there is as much as a couple second delay for the red X to go away but it’s nothing that kept me from working ahead or doing anything. In most cases the abort confirmation box came up right away but in the attached video you can see it once took a couple seconds. But nothing about it was disruptive to my work.

 

But at some point I noticed after running and aborting several times Forrest (The running man) was still running even though the macro was stopped. I could right click him several times and he would keep running and report that the macro was aborted each time. But after hitting the red X it cleared him out again.

 

Now a while ago I found a bug in the way the F9, its icons, and the running man worked and it was fixed. I remember writing a post with something like “Run Forrest, run!” in the title but I’ll be damned if I can find it now. You might want to look around for it. I think this may also have been related to the fact that the F9 to F8 mode change wasn’t working properly after breakpoints. But I might have this wrong. In any case I seem to remember it was fixed in a later version. Which version are you running? You might want to start a support incident with ISS.

Repeat_stop.wmv

Link to comment
Share on other sites

Cory,

 

I am running 3.7.4.1. I am assuming this is THE latest version?

 

Try doing this: 1) Go to "debug" on the menu, 2)Step Through macro 3) Run your macro(It has to be a Repeat with Folder)by clicking it one step at a time and THEN try using the RED X or stopping it with the running man IN THE MIDDLE OF THE PROCESS. DON"T LET IT GET TO THE END.

 

The Red X and the running man linger for a LONG TIME and I don't have time to stop it and start again when I am trying to test it. IT MAKES ME MAD. I could go out and have a half cigarette while it's trying to correct itself.

 

Will the owners of Insight please step up to the plate please?

 

-P

Link to comment
Share on other sites

I see you're using F8, not F9 as I was. This is slightly different and I do see more delay. I opened the macro in the scripting editor and hit F8 several times then hit the red X or Forrest (running man). The dialog immediately popped up and confirmed it was aborted. I still have the red X and Forrest. However I can edit commands and do anything I please in the scripting editor. After ~15 seconds both Forrest and the red X disappeared. So my experience is that it's an annoyance but it wouldn't hurt my productivity any. If you can smoke half a nail then we must have something different between our two machines. Have you started a support incident with ISS? I am still on 3.7c (3.7.3.1) and you have the most recent version.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...