Jump to content
Macro Express Forums

ctrl combination type text


vryl
 Share

Recommended Posts

That was an interesting question. I assume you actually want to type that phrase (such as for an instruction manual) rather than simulating Ctrl+letter. When you enter the Text Type dialog, check the "Use Clipboard to Paste Text" option. That will paste <CTRLD>letter<CTRLU> verbatim.

 

That contrasts with the normal usage, where in Text Type you would click Control Down, the letter, Control Up with the default "Type Text Normally" selected. So with letter "C" it would copy. Alternatively Control+letter. If you are having trouble getting a keystroke to function you can set "Auto Restore Keyboard Hooks" in Options/Preferences/Miscellaneous. There is also a "Reset Hooks" command in ME Scripting Editor, item Macro Express. There are other aspects such as out of Scope; the window being operated on loses focus or is not present.

Edited by JohnS
Link to comment
Share on other sites

Does your script command look like this? For example, for Control-c (copy to clipboard):

Text Type: <CTRLD>c<CTRLU>

 

Where do you put the delay? If you think the macro is feeding the keystrokes faster than the application can accept them, then try preceding your Text Type command with something like:

Keystroke Speed: 30 Milliseconds

Link to comment
Share on other sites

That was an interesting question. I assume you actually want to type that phrase (such as for an instruction manual) rather than simulating Ctrl+letter. When you enter the Text Type dialog, check the "Use Clipboard to Paste Text" option. That will paste <CTRLD>letter<CTRLU> verbatim.

 

That contrasts with the normal usage, where in Text Type you would click Control Down, the letter, Control Up with the default "Type Text Normally" selected. So with letter "C" it would copy. Alternatively Control+letter. If you are having trouble getting a keystroke to function you can set "Auto Restore Keyboard Hooks" in Options/Preferences/Miscellaneous. There is also a "Reset Hooks" command in ME Scripting Editor, item Macro Express. There are other aspects such as out of Scope; the window being operated on loses focus or is not present.

I have just tried all of them, but nothing works.

Link to comment
Share on other sites

Does your script command look like this? For example, for Control-c (copy to clipboard):

Text Type: <CTRLD>c<CTRLU>

 

Where do you put the delay? If you think the macro is feeding the keystrokes faster than the application can accept them, then try preceding your Text Type command with something like:

Keystroke Speed: 30 Milliseconds

Exactly. I put the delay between <CTRLD> and the letter. Unfortunately, my ME version does not give any keystroke speed option.

Link to comment
Share on other sites

Exactly. I put the delay between <CTRLD> and the letter. Unfortunately, my ME version does not give any keystroke speed option.

Are you sure? If so, you must be using a very old version! I strongly recommend upgrading to the latest version of ME3.

Link to comment
Share on other sites

Did you try Control+letter rather than using the Up and Down? This is an issue that Paul and I constantly bat around! My experience has been that the separate commands don't make a difference (and I've tried) whereas Paul is the opposite. Paul is more concerned with multi-use whereas I only have a couple of PCs. You don't mention the letter. Regardless of how ME behaves, you should try and avoid common hotkeys/shortcuts whether related to an application or Windows.

 

I've also found repeating the Ctrl+letter command will work in some applications. For example, in Firefox Ctrl+L gives the location bar. Sometimes "Find" or "Quick Find" would be started instead. Adding a time delay was actually counter-productive. I repeated the Ctrl+L instruction immediately which improved reliability (same command twice). Where possible, I now use the "Web Site" command with the default browser instead.

Link to comment
Share on other sites

Make sure you are using lower case letters.

 

...Firefox Ctrl+L gives the location bar.
Not exactly true. Ctrl+l gives the location bar, Ctrl+L does not (on my computer).

 

When you use an upper case letter like Ctrl+L or <CtrlD>L<CtrlU>these keystrokes are sent: <CtrlD><ShiftD>l<ShiftU><CtrlU> (where l is lower case L). Often, as in the case of Firefox this does not work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...