Jump to content
Macro Express Forums

Identify this Insight macro?


Recommended Posts

This is frustrating me out of all proportion!

 

Every time I run Services (e.g. via XP Control Panel > Administratve Tools > Services) an ME Pro macro runs. I'm trying to find out what the macro is. First, I ran it, answering the 3 or 4 questions and then checked ME Pro Explorer sorted by Last Run Time. Which shows nothing. No macro has been run in the last 5 minutes! (But then this feature has always been unreliable IMO.) So I ran it again. It's a trivial demo that first displays this TBD:

 

MEProServices.jpg

 

But no clues there so I look at the Running Man. That just says either 'Macro Express Pro -' or 'Macro Express Pro - Macros Running'. Not very helpful:

 

MEProMan-1.jpg

 

Her's the last dialog:

 

MEProMan-2.jpg

 

I've browsed through my thousand or so macros in this file but so far cannot locate it. I got close, with one promisingly called 'Multiple Choice DEMO', but that's clearly a little more recent because the final question is:

 

MEProServices2.jpg

 

Can anyone identify it please?

 

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Can anyone identify it please?

Hi Terry,

My best guess is you can identify it yourself :) Here's how:

 

You probably have disabled the dialog informing you when you cancel a macro. So first, enable it.

Preferences > General > Dialogs > Inform the user when a macro has been cancelled.

Now, trigger the macro that you wanna find the name of. Cancel the macro (by shortkey or right click the running man). A dialog with the name of the macro cancelled should pop up.

 

Hope it helps.

Link to comment
Share on other sites

Thanks Arek, I hadn't thought of that method - but unfortunately it doesn't work with this macro! I cancelled another, known, macro and that was correctly reported.

 

This one therefore remains infuriatingly elusive. I'm hoping one of the long term users (or Insight, of course) will recognise it from my screenshots.

 

I tried running Process Monitor directly before triggering it, but my attempts to filter the thousands of entries generated by ProcMon have so far failed.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

unfortunately it doesn't work with this macro!

I truly didn't see this coming! Does the dialog not pop up at all or pops up with the name part empty? Anyway, no hope in this method.

 

If nobody recognises the macro you might consider doing this:

Export 100 macros to one .mex file. Open it in a text editor and look for phrases from the TBD i.e. "This macro will pose a question".

1. If you find this string, export 50 macros to one file and 50 to another. And repeat process untill you get like, I don't know, 10 macros, you then should easily find the macro.

2. If the first hundred didn't contain the phrase, export another batch of macros.

You just have to make sure not to export the macro 'Multiple Choice DEMO' along with the others.

 

Now I know it's as lame as it can get, no NASA scientist would ever use it, but it sure does work.

Link to comment
Share on other sites

No dialog, zilch! A puzzle in its own right, because logically I see no reason it shouldn't work. But then, IMO, so should the Last Run Time I mentioned.

 

Your suggested method is essentially the one I propose to use if I have to. Although my approach will be much faster using the search macro from Cory that was the subject of this recent thread:

http://pgmacros.invisionzone.com/index.php?showtopic=4666

 

Hmm, I see that several subsequent posts I made appear to have been removed. Presumably those in which I reported I'd disappointingly had no feedback from Insight, despite sending them a copy of the macro and full details. (I've still had no feedback, nor even an acknowledgement that the problem is recognised or has been reproduced.)

 

Anyway, as you see, running that very handy macro to search for identifying text requires first re-installing 4.1.6.1, because it refuses to run in 4.2.1.1. I'll do it tomorrow if I don't get any identification beforehand.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Just a couple of thoughts:

 

 

  • Don't forget that there was and possibly still is a bug in the last run time where it's not refreshing. Try closing and reopening.
  • Also if you enable global logging you should be able to see which one is running.
  • You mentioned having ME3 still around in another post. Might need to check any of those files.
  • If you have your files indexed with Windows Search you should be able to find it with a simple search.
  • A few years ago I picked up the habit of setting a variable for macro name at the beginning of all my macros then using that as the title or part of the title of all my dialog boxes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...