Jump to content
Macro Express Forums

Audio Mute: quiet but not silent?


Recommended Posts

Not exactly a major problem, this, but I'm curious. I've used the Audio Mute Toggle command in a few macros recently, typically immediately before a command to save a file, in order to silence the warning sound that accompanies the message 'Save changes to xyz?'. But I note that, although it's much quieter, it's not mute.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

No idea. It's completely quiet for me.

 

Thanks for checking. Strange. Some characteristic of my RealTek on-board sound card perhaps. I'd say it was about -20 dB. I'll check it with a WAV or MP3 next, in case it's just 'Windows sounds' that raise the issue.

 

--

Terry, UK

Link to comment
Share on other sites

I tested as planned with WAV and MP3. Mute produced silence. I re-tested my original macro and again got a very quiet result, but not mute.

 

Here's my simple test macro:

 

Audio Mute Toggle // Switch off sound.

Program Launch: "Test.txt" (Normal)

Parameters:

Text Type (Simulate Keystrokes): x

Delay: 0.1 seconds

Text Type (Simulate Keystrokes): <CONTROL><F4>

Delay: 0.1 seconds

Text Type (Simulate Keystrokes): y // YES to question 'Save changes to Test.txt?'

Audio Mute Toggle // Toggle sound back on.

 

Is it only possible to attach a file to original posts, i.e. thread starters? I'm sure I've been able to do so in replies before? Anyway, here it is:

http://dl.dropbox.com/u/4019461/TestMute.mex

 

Cory: What did you test it with before your earlier reply please?

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Thanks for the macro but that doesn't work for me. Apparently in W7 Notepad doesn't make a sound for that dialog. But I played with the Multimedia Beep command and was able to create the symptom you describe. First off the 100mS timing resulted in no apparent mute to the beep. I think this is because it takes the system longer to execute and play the snippet than 100mS. For instance if I changed the values to 1S there was no apparent sound. But if I tweaked with the delay value I would get a quiet beep. If you look at a plot of the levels the sound does not go from 100% to zero instantly. It trails off. So I'm thinking in this case if you were to increase you timing you could eliminate the sound completely.

 

I would just like to get on a soapbox for the moment. The definition of mute is to "Deaden, muffle, or soften the sound of", not to turn off. Musicians have a device called a mute but it doesn't eliminate sound. And I don't like the modern idea that mute is associated with no sound. And early on there were TV's and such that had a mute button but it only attenuated the sound for commercials. I'd like to have a real 'mute' button again. Or maybe a two step button. Click once for mute, and again for sound off.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...