Jump to content
Macro Express Forums

User Account Control Window


Recommended Posts

Hey everybody! I know it's been years since I've posted, and I've missed this place a lot. I changed jobs and my new employer didn't want to automate anything.

 

Anyway, I've moved again and now I have a forward-thinking, efficiency-driven employer once again, who has allowed me install MEP on my machine.

 

Not less than 24 hours later I started running into an issue that I'm hoping can be fixed. It's been so long since I had to build a macro from scratch that I may just be missing something obvious, but it also may be a limitation of Windows (or of my machine due to Administrative lockdowns).

 

Here we go:

 

I have a timekeeping program that I have to run at the end of the day. I'm not trying to automate that program, specifically, but I am trying to automate the launching of the program.

 

Here's the process and the problem.

 

  • I use a Launch command to launch the program.
  • I use a Macro Run command to input the User ID and Password (I have a password macro that enters passwords for me so I don't have to remember all of them as they each have different security level requirments and min/max characters)
  • I have tested to make sure that the macro is not getting stuck in the called "password" macro... it is returning successfully to the parent "launch" macro.
  • At this point, the computer always gives a User Account Control prompt. I can't seem to find any way to eliminate that prompt, and MEP seems to completely ignore that window when I use Wait for Window, Activate Window, or even if I just put in a delay followed by a Text Type <ENTER> to move past that prompt.

There are more problems after this one, such as Java prompts that the macro also appears to be ignoring, but this is the one that I need to know right up front if MEP has the ability to manipulate or not.

 

I tried to get a screenshot of the prompt, but for whatever reason I couldn't do that, either.

 

Any thoughts?

 

Link to comment
Share on other sites

I have never had any success circumventing UAC but I never tried hard. Given its designed to prevent exactly what you are trying to do I doubt there is any way to do anything when a UAC prompt is active. I think you need to work on avoiding getting the prompt in the first place.

 

Does this timekeeping software cause a UAC prompt if launched from the Start menu? If not find out how you can launch that. One thing you can do is in the windows shortcut you can assign a hotkey. Perhaps use the same one you are using for the macro then activate the macro on the window appearing. Or use the Macro Run command to launch the LNK file. Also you might try disabling UAC. Although your admin staff might have policies against that. Another idea is maybe MEP needs to be running with elevated permissions.

Link to comment
Share on other sites

There is a way to use the Task Scheduler to launch a program with elevated privileges without causing the UAC prompt. You can do a Google search for details or perhaps you can adapt this article that talks about launching Macro Express with elevated privilegese without the UAC prompt: How to Run Macro Express as Administrator when Windows Starts.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...