Jump to content
Macro Express Forums

Missing Process from Running Process List


Recommended Posts

I need to be able to terminate a malfunctioning process and restart it. To do this the malfunctioning process needs to be seen by Macro Express Pro. However, it is not listed in the Running Processes list. The process exists and is active when I look at Windows Task Manager. A work around is to create a batch file with the PSKill.exe program set to kill the process. However, I wonder why Macro Express cannot see certain processes so as to terminate them. I am running Windows 7 64.

Link to comment
Share on other sites

Good question. I created a macro to make a list of processes and it only found 44 of the 94 processes on my system. A quick compare shows that the MEP command is only returning processes from the current session (1). IE services and the like are not apparent. I have made a feature request to ISS to give us the option to include all processes or at least update the help file.

 

 

 

My suggestion to you is to use the Tasklist.exe program instead. With its command line option you can actually create a report file in CSV. Now use the ASCII File Process command to plow thru it. Also you might consider using the TaskKill.exe to kill the processes since it’s native to W7 and has a “force” parameter.

 

 

Link to comment
Share on other sites

Good question. I created a macro to make a list of processes and it only found 44 of the 94 processes on my system. A quick compare shows that the MEP command is only returning processes from the current session (1). IE services and the like are not apparent. I have made a feature request to ISS to give us the option to include all processes or at least update the help file.

 

Interesting, and prompted my own comparison which might shed some light:

 

Tool                 Processes reported
----------           ------------------

XP Task Manager            80
Process Explorer           81
Tasklist                   81 (but with a few compensating differences)
ME Pro                     70

 

The 11 missing from ME Pro were:

 

alg.exe

csrss.exe

DivXUpdate.exe

nTuneService.exe

svchost.exe (4 versus 8)

System

System Idle Process

wmiprvse.exe (nor in TM)

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...