Jump to content
Macro Express Forums

Mouse Locator puzzle


Recommended Posts

I use the Mouse Locator frequently so I have a hotkey macro assigned to it:

 

<PROGRAM LAUNCH Path="C:\\Program Files\\Macro Express Pro\\MSLocate.exe" Mode="\x00" Default_Path="FALSE" Wait="1" Get_Console="FALSE"/>

 

Does anyone know why that only displays the decimal value of the pixel colour please? If instead I run Mouse Locator from within ME Pro, I get to see the hex value too. As I'm currently trying to write some simple scripts with AutoHotkey (which appear to use only hex values), I need that. Is there perhaps some command setting I can apply to MSLocate.exe?

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

When I use Macro Express, I use the Mouse Locator tool. When I use AutoHotkey, I use its Spy feature.

 

But apart from being less compact AU3_Spy is rather slow. Here, it takes several seconds to appear (from hotkey macro activation), and even then is initially 'dormant'. Whereas my macro launches MSLocate in a fraction of a second, and it immediately displays position and pixel colour. My new macro that runs ME Pro > Tools > Launch Mouse Locator, for when I need the hex colour, also takes about 4-5 seconds, most of which is for opening and closing ME Pro Explorer.

 

--

Terry, East Grinstead, UK

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...