Jump to content
Macro Express Forums

Macros from Shortkey stopped workig (Macro Express 5, 30 day trial)

Recommended Posts

Hi - I downloaded the 30 day trial to share it with and suggest it for an office. I set up three shortkey macros, all worked immediately, and when I returned 30 minutes later, none worked.


I have read through hours of this forum, Googled, and poked around - I'm sure it's an obvious, dumb mistake, but I can't figure out what I might've changed.


Can anyone suggest something to check, or let me know what information you need to help identify the error?

Link to comment
Share on other sites

I am not having any good ideas pre-coffee-effect.
Look in the Macro Explorer and see if the Last Run Time is changing.

Make sure MEP is still running. You shoudl see it in the Windows System Notification Area. 
What happens if you run it from the Macro Explorer window or Macro Editor?

I'll try to think of something else. 

Link to comment
Share on other sites

Grr, thanks. This may be too small potatoes to revisit. It's only working when I hit the play button to "force run" the Macro. Then, data appears in the "Macro Logs" file that starts this way:


Tuesday, November 21, 2023 11:18:18:668 AM: TMainWin.tmrFixFirstLineTimer: An error in the first line of the script has been fixed.
  From:    Text?
  To:    Text Type (Simulate Keystrokes): 

Link to comment
Share on other sites

So there's an error in the macro. So it's running, just aborting before any visible activity. 

Also I was wonder how you have the scope set. For instance sometimes people set it to the window title but if it's an exact match and something like the document tittle is in the title bar, it will not work. 

Is it working now?

Link to comment
Share on other sites

If I open the Macro, select "Test Run" and select the window I want (Notepad), it'll play. But "Test Macro Now" doesn't seem to do anything. Since it worked before, I don't think it has to do with permissions on my work laptop, although I did need to call the company's IT to get the trial installed. Thanks for your review and thoughts, and please, please let me know if anything else comes to you! I'm bummed, but'll see if anything occurs to me later, too.

Link to comment
Share on other sites

When you click the Run Macro Now it doesn't ask you which window to type in. Since the first line is a Text Type command Macro Express is typing into it's own window. The text is typed into the window that has focus.


The log entry "Tuesday, November 21, 2023 11:18:18:668 AM: TMainWin.tmrFixFirstLineTimer: An error in the first line of the script has been fixed" happens when there was a problem displaying the first line of a macro in the Script Editor. It has no effect on the macro running.


Log entries that include MacScript are events that occur in the Script Editor. Entries that include MacEdit are events that occur in the Macro Express Explorer. For events that occur in the Player look for log entries that include MacExp.


Here are some things to try:


1. Press and release the Ctrl key and then type the shortkey activation again.


2. Make sure you are typing the correct characters to activate the shortkey. Highlight the shortkey macro in the Macro Express Explorer window. In the yellow box under the list of macros the keys needed to activate the shortkey are displayed. For example, it may show something like  Shortkey   //ps


To activate the shortkey macro type all the keystrokes shown.


3. You can adjust what is needed to activate shortkeys in the Activations, Shortkeys preferences. Depending on those settings you may need to press space before or after the shortkey characters.


4. To see if the macro is activating put something at the top of your macro like a Text Box Display. You could also have Macro Express play a sound when a macro is activated. This is found in the Playback, Miscellaneous preferences. But it is annoying to have a sound played every time a macro is activated so you will probably want to turn this off after your test.



Link to comment
Share on other sites

Wow. Nothing makes me both more relieved and feel worse than having "restart the computer" do the trick.


I'm mortified and grateful for everyone's quick and generous help. Thank you!


I'll keep the rest of this advice on hand for the next time I run into any issue...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...