Jump to content
Macro Express Forums

Macro Express 6 fails to type the text.

Recommended Posts

This is MacroExpress failure to execute any of my text-typing macros when I do my usual MX prefix command.


MacroExpress had been failing in (that was why I installed the 6 version, hoping it would solve the problem)


When the macro executes first time, I can see an attempt to type characters, but the cursor does not actually type visible characters, and quickly jumps back to the original position.
After that, execution does nothing whatsoever, unless I Ctrl-Alt-Del and End task, and then reload MacroExpress.


I've tried rebooting. It still fails.

Various text macros fail, not just one.

My spreadsheet cell-stepping macros works okay.

Link to comment
Share on other sites

3 hours ago, amonaghan said:

Try adding a Keystroke Speed at the beginning of the macro. I usually use 50ms and then lower the time until it fails

Also check Options | Preferences | Playback | Delay After Keystroke Down (and UP).  On my system, both items are check-marked, and the suggested 300 microseconds is specified. 


Are these macros that previously worked, and are now failing?  Or have they never worked reliably?  Is your PC fairly modern?  What version of Windows?

Link to comment
Share on other sites

What prefix are you using? Test your macros with a different prefix, preferably one-character long instead of the two-character default "##", e.g.,:



or something similar.


What applications are your macros failing in?


Is the scope of these macros global or window/program specific?


Do the macros fail if you add a hotkey activation?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...